itkorea 인천 아카데미 클라우드 정보보안 수업 자료 및 정리
2024-11-25~2025-05-13
정식 수업~
매주 월화수목금 9시30분-6시30분까지 과정
ACL remark(주석) 명령어
Router > enable
Router# 최고 관리자 권한으로 접속(15레벨) 그래서 계정 만들때 0~15레벨 지정가능함
15레벨을 제외한 나머지 레벨은 명령어 사용에 제한적이다
conf t
username [계정명] privilege [레벨숫자;디폴트는15레벨] password [암호]
[실습] 레벨별 로그인 접속 테스트할꺼임
사전사업
-계정 생성 & 암호지정 & 레벨지정>옆사람이 들어오게 설정해줘야함 (유저명은 옆사람 영어이름 & 암호는 banana & 레벨은 1-14까지는 뭘줘도 똑같음, 15만 아니면 다 제한적임, 근데 왜 15개냐? 역할을 다르게하기위해서)
-conf t
username gildong privilege 1 password banana
---나중에실습----
-텔넷 허용되어있어야함------------->텔넷암호는 telpass
-conf t
line vty 0 4
password telpass
login
transport input telnet
-관리자 암호 설정되어있어야함--->암호는 cisco
-conf t
enable sercret level 1 cisco------>옆사람 라우터에 접속할때, 첫번째 텔넷 암호 입력, 두번째 enable 1치기(1의 암호는 cisco에요가 되는거임 레벨별로 암호가 되는거임)
요건 레벨2 예시 enable sercret level 2 apple
오후 1:54 2025-01-02 0102 previlage lab
R1
conf t
int e0/0
ip add 172.3.1.254 255.255.255.0
no sh
int e0/1
ip add 10.1.23.2 255.255.255.0
no sh
router ospf 1
network 172.3.1.0 0.0.0.255 area 0
network 10.1.23.0 0.0.0.255 area 0
end
copy r start
conf t
line vty 0 4
password telpass
login
transport input telnet
conf t
enable secret level 1 cisco
enable secret level 2 apple
conf t
username hyojeong privilege 1 password banana
는 안되서...lab 수정 ㄱㄱㄱ
R1
conf t
int e0/0
ip add 172.3.1.254 255.255.255.0
no sh
int s2/0
ip add 172.3.12.1 255.255.255.0
no sh
router ospf 1
network 172.3.1.0 0.0.0.255 area 0
network 172.3.12.0 0.0.0.255 area 0
end
copy r start
R2
conf t
int e0/0
ip add 172.3.2.254 255.255.255.0
no sh
int s2/0
ip add 172.3.12.2 255.255.255.0
no sh
router ospf 1
network 172.3.2.0 0.0.0.255 area 0
network 172.3.12.0 0.0.0.255 area 0
end
copy r start
R1
conf t
line vty 0 4
password telpass
login
transport input telnet
conf t
enable secret level 1 cisco
enable secret level 2 apple
level 2 level 3는 핑만되고, sh run은 안됨
R1
conf t
privilege exec level 2 show running-config
근데 안됨;; 오류인듯
telnet에서 접속방법, 1. 텔넷 비번 2.텔넷아이디 비번으로 들어가게됨(login local 명령어로 사용)
R2(config)#menu user title "Choice Command"
R2(config)#menu user text [1]. "show interface"
R2(config)#menu user text [2]. "show interface serial 2/0"
R2(config)#menu user text [3]. "telnet"
R2(config)#menu user text [4]. "show ip route"
R2(config)#menu user text [5]. "ping"
R2(config)#menu user text [q]. "exit"
menu user title "Choice Command"
menu user text [1]. "show interface"
menu user text [2]. "show interface serial 2/0"
menu user text [3]. "telnet"
menu user text [4]. "show ip route"
menu user text [5]. "ping"
menu user text [q]. "exit"
menu user command 1 "show interface"
menu user command 2 "show interface serial 2/0"
menu user command 3 "telnet"
menu user command 4 "show ip route"
menu user command 5 "ping"
menu user command q "exit"
menu user line-mode
R2(config)#menu user command 1 "show interface"
R2(config)#menu user command 2 "show interface serial 2/0"
R2(config)#menu user command 3 "telnet"
R2(config)#menu user command 4 "show ip route"
R2(config)#menu user command 5 "ping"
R2(config)#menu user command q "exit"
R2(config)#menu user line-mode
username network1 privilege 15 password cisco
username network1 autocommand menu user
username admin privilege 15 password admin
line vty 0 4
login local
0102-02 server lab
오후 1:54 2025-01-02
0102 previlage lab
R1
conf t
int e0/0
ip add 172.3.1.254 255.255.255.0
no sh
int s2/0
ip add 172.3.12.1 255.255.255.0
no sh
router ospf 1
network 172.3.1.0 0.0.0.255 area 0
network 172.3.12.0 0.0.0.255 area 0
end
copy r start
R2
conf t
int e0/0
ip add 172.3.2.254 255.255.255.0
no sh
int s2/0
ip add 172.3.12.2 255.255.255.0
no sh
router ospf 1
network 172.3.1.0 0.0.0.255 area 0
network 172.3.12.0 0.0.0.255 area 0
end
copy r start
R1
conf t
privilege exec level 2 show running-config
enable secret level 14 watermelon
-----------------------------------------------------------
오후 3:20 2025-01-02
R1
conf t
int e0/0
ip add 172.3.1.254 255.255.255.0
no sh
int e0/1
ip add 172.3.2.254 255.255.255.0
no sh
int e0/2
ip add 192.168.10.224 255.255.255.0
no sh
router ospf 1
network 172.3.1.0 0.0.0.255 area 0
network 172.3.2.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
end
copy r start
---------------------------------------------
인터넷 연결 config
R1
conf t
ip route 0.0.0.0 0.0.0.0 192.168.10.1
access-list 31 permit 172.3.0.0 0.0.255.255
ip nat inside source list 31 int e0/2 overload
int e0/0
ip nat inside
int e0/1
ip nat inside
int e0/2
ip nat outside
int e0/3
end
wr
SERVER DHCP
Dynamic Host Configuration Protocol
DHCP HORA 프로세스
1. 컴퓨터가 켜지면, 서버한테 브로드캐스트 보내서 저 아이피좀 주세요!!함(이걸 Discover라고함)
포트번호 udp 67번을 통해서
2. 서버: ㅇㅇ 나 아이피있는데 너 이거 쓰실?(Offer)
3. 클라이언트: 좋아영~ 저그거쓰고싶어요! (Request)
4. 서버: ㅇㅋㅇㅋ 쓰삼~~ 거래완료~~(Acknowlegment)
그리고 아이피 다쓰구 임대 기간 끝~ 그럼 아이피 반남하구, 그 아이피는 또 다른 클라이언트에게~
주의사항
단일네트워크에서는 DHCP 하나밖에 작동못함. Bridged에서는 한개밖에 못돌림. 중복이라 의미가 없어서
와이어샤크로 DORA꼭 확인하기
DHCP 운영할 서버는 해당 네트워크 대역의 아이피를 고정으로 할당해주어야 한다
서버는 공인아이피를 사용하고 고정아이피를 할당해줘여한다
공인아이피->인터넷 가능(전세계 유일 IP)
사설아이피->인터넷 불가(중복가능IP)
NAT: 공인아이피->사설, 사설->공인
그래서 우리 랩에서는 일단 R91부터 DHCP 작업한후, PC 2에 IP 자동으로 받게하게할꺼임
아이피 대역 172.16.1.0/24 -> 전체 아이피는 256개
사용할 수 없는 아이피는 몇개? 4개
1. network-id
2. boradcast address
3. gateway ip address
4. server ip address
DHCP 로키9에서 세팅하기
DHCP 홈 디렉토리로 이동
default-lease-time 600;
max-lease-time 7200;
authoritative;
subnet 172.3.1.0 netmask 255.255.255.0 {
option routers 172.3.1.254;
option subnet-mask 255.255.255.0;
option broadcast-address 172.3.1.255;
range 172.3.1.50 172.3.1.80;
option domain-name-servers 168.126.63.1;
}
2.dhcp 임대파일 작성하기
3. DHCP 데몬 재실행
만약 데몬 ERROR 발생시
systemctl status dhcpd -l 해서 뭐때문에 에러났는지 보이니까 그거 보고 찾아내기
4.GNS3로 와서 virtural pc1에 ip dhcp 입력해보자
[조별실습] 우분투에서 dhcp 서버 세팅하기
apt install -y isc-dhcp-server(우분투 dhcp 서버 설치 방법)
windows 2022 DHCP 서버 설정
ISP에서 기본제공하는건 3일임
'Study > Information Security' 카테고리의 다른 글
클라우드 정보 보안 수업 자료 및 정리 [28회차, DNS, Master, Slave] (1) | 2025.01.06 |
---|---|
클라우드 정보 보안 수업 자료 및 정리 [27회차, DHCP, DNS] (2) | 2025.01.03 |
클라우드 정보 보안 수업 자료 및 정리 [25회차,Oracle, ACL Named] (2) | 2024.12.31 |
클라우드 정보 보안 수업 자료 및 정리 [24회차, acl, Oracle] (0) | 2024.12.30 |
저장용 (0) | 2024.12.27 |