2024-11-25~2025-05-13
정식 수업~
매주 월화수목금 9시30분-6시30분까지 과정
LVM의 목적은 두가지
1. 디스크 파티션을 효율적으로 관리할 수 있다
2. 파티션 용량이 부족할때 다른 파티션이나 새 하드디스크를 추가하여 확장할 수 있다
3. 최근의 리눅스 배포판들은 설치할 때 LVM으로 기본 구축되어있다
4. RAID 0과 비슷한 개념으로 생각하면된다
5. LVM Type은 8e (에코)
LVM 실습 과정
0. 새 하드 디스크를 fdisk 에서 8e 타입 선언
1. PV생성 (fdisk에서 파티션 생성의 개념과 비슷)
-fdisk에서 8e로 선언한 하디스크를 lvm 작업용으로 선언
-pvcreate(생성) / pvscan(확인)
2.VG 생성(확장 파티션 개념이라 생각)
-pvcreate로 생성한 하드디스크를 VG(volume group)으로 생성
-vgcreate(생성) / vgscan(확인) / vgdisplay(확인)
3. VG 활성화
-생성된 volume group을 활성화
-vgchage
4. LV 생성(주파티션 또는 논리 드라이브의 개념과 비슷)
-실제 하드 디스크를 사용
-lvcreate(생성) / lvscan(확인)
5. 파일시스템 생성
-mkfs / mke2fs
6. 마운트
-mount / umount
7. 자동마운트
-/etc/fstab 파일에 등록해서 사용
하드는 전체용량의 70% 이상 쓸때 속도가 느려짐
70% 되는 시점에, 하드 디스크를 증설해야겠쬬 그래서
raid 0 은 처음 구성하면 구성한대로 가야해서
LVM은 그게 아니고, 하드에 연결 가능해서 연결하는 족족 용량이 늘어나는거임 요즘은 필수
LVM 작업시 사전 작업 조건 2개
1. 하드가 8e로 선언되어있어야하고
2. PV이 선언이 되어있어야함
LV은 우린 단일로 지정
ext4로 세팅
xfs 리눅스 최신버전
reisefs는 윈도우11
스냅샷 돌려서 for문으로 여기까지 script 짜기
위 스크립트에서 pvscan 오류가 발생할 수 있는 원인과 해결 방법을 단계적으로 분석합니다.
문제 분석
- 스크립트에서 확인해야 할 주요 사항
- hdd 변수의 정의가 잘못되었습니다.
- hdd는 쉘 스크립트에서 배열처럼 사용되었지만, 쉘에서는 배열 사용 방식이 다릅니다.
- sfdisk 및 pvcreate 명령어가 올바르게 실행되었는지 확인 필요.
- hdd 변수의 정의가 잘못되었습니다.
- 오류 발생 원인
- hdd 변수 정의 오류: 쉘 스크립트에서 배열 선언 및 순회 방식이 잘못되어 명령어가 올바르게 실행되지 않았을 가능성.
- 디스크 파티션 문제: sfdisk 명령어 실행 중 파티션이 제대로 생성되지 않거나 /dev/sd[i]1 파티션이 존재하지 않을 가능성.
- pvcreate 명령어 실패: 디스크가 초기화되지 않거나 파티션 타입이 LVM(8e)으로 설정되지 않았을 가능성.
수정된 스크립트
쉘 스크립트에서 배열을 올바르게 정의하고 순회 방식도 수정하여 정상적으로 동작하도록 합니다.
#!/bin/bash
# 디스크 설정
hdd=("c" "d" "e" "f" "g" "h" "i" "j" "k")
# sfdisk 명령어로 파티션 덤프
sfdisk -d /dev/sdb > /tmp/lvm_test.dmp
# 각 디스크에 동일한 파티션 생성
for i in "${hdd[@]}"; do
sfdisk -f /dev/sd"$i" < /tmp/lvm_test.dmp
done
# 생성된 파티션 확인
fdisk -l /dev/sd[c-k]
# 물리 볼륨 스캔
pvscan
# 각 디스크의 첫 번째 파티션을 물리 볼륨으로 생성
for i in "${hdd[@]}"; do
pvcreate /dev/sd"${i}"1
done
# 물리 볼륨 스캔
pvscan
변경된 점
- hdd 배열 정의:
- 쉘 스크립트에서 배열은 ()를 사용하여 선언하고, 배열 요소는 " "로 구분합니다.
- for 루프에서 배열 요소를 사용하려면 "${hdd[@]}" 형태로 접근해야 합니다.
- sfdisk와 pvcreate 명령어:
- sfdisk로 각 디스크에 동일한 파티션 레이아웃 적용.
- 디스크 이름과 파티션 번호를 명확히 지정.
- 오류 방지:
- 각 명령어 실행 후 오류 메시지를 확인하도록 설계 가능:
sfdisk -f /dev/sd"$i" < /tmp/lvm_test.dmp || echo "Error with /dev/sd$i"
- 각 명령어 실행 후 오류 메시지를 확인하도록 설계 가능:
오류 해결 방법
1. 디스크 상태 확인
- pvcreate 명령어 실행 전에 디스크 상태를 확인:
- fdisk -l /dev/sd[c-k]
- 파티션이 올바르게 생성되지 않았다면 sfdisk 실행을 확인:
- sfdisk -d /dev/sdb
2. 파티션 타입 확인
- 파티션 타입이 LVM(8e)으로 설정되었는지 확인:
fdisk /dev/sdc
- t 명령어로 파티션 타입을 확인하고 필요시 변경.
3. 물리 볼륨 생성
- 각 디스크의 첫 번째 파티션을 물리 볼륨으로 생성:
- pvcreate /dev/sdc1
- pvcreate 실패 시 오류 메시지를 확인하여 문제를 해결:
- "Device is not initialized" → pvcreate 전 파티션 타입 확인 필요.
- "Device is in use" → 디스크가 다른 프로세스에 의해 사용 중일 가능성.
4. 물리 볼륨 스캔
- pvscan 명령어로 디스크 상태를 다시 확인:
pvscan
결론
- 스크립트에서 배열 정의 및 명령어 사용 방식을 수정하여 pvscan 오류를 해결할 수 있습니다.
- 파티션 타입, 생성 여부, 디스크 상태를 사전에 확인하여 오류를 방지하는 것이 중요합니다.
- 수정된 스크립트를 사용하면 LVM 구성이 정상적으로 작동할 것입니다. 😊
옆자리 파트너 이름 choi/hyojeong/으로 작업
선생님 이름do/hyunteacher로 작업
#!/bin/sh
vgcreate do /dev/sdh1 /dev/sdi1 /dev/sdj1
vgdisplay -v do
lvcreate -l 765 do -n hyunteacher
lvscan
mkfs.xfs /dev/do/hyunteacher
mkdir lvm_test3
mount /dev/do/hyunteacher lvm_test3
df -h
오후 수업 네트워크
1220-02 ospf lab
다시 config 줏어옴
오후 3:51 2024-12-20
1220-02_OSPF 2 LAB CONFIG
서브넷 다 같음
OSPF
R1-R10 RIP 사용
AREA는 총 3개 0 1 2
IP 2개 ASBR 1개 ABR 1개
전체네트워크는
172.16.1.0
172.16.2.0
172.16.3.0
172.16.4.0
172.16.5.0
172.16.6.0
172.16.7.0
172.16.8.0
172.16.9.0
192.168.10.0
PC1
ip 172.16.1.1/24 172.16.1.254
PC2
ip 172.16.2.2/24 172.16.2.254
PC3
ip 172.16.3.3/24 172.16.3.254
PC4
ip 172.16.4.4/24 172.16.4.254
PC5
ip 172.16.5.5/24 172.16.5.254
PC6
ip 172.16.6.6/24 172.16.6.254
PC7
ip 172.16.7.7/24 172.16.7.254
PC8
ip 172.16.8.8/24 172.16.8.254
PC9
ip 172.16.9.9/24 172.16.9.254
PC10
ip 192.168.1.10/24 192.168.1.254
--------------------------------------------------------
R4
conf t
int e0/0
ip add 172.16.4.254 255.255.255.0
no sh
int s2/0
ip add 172.16.34.4 255.255.255.0
no sh
int s2/1
ip add 172.16.45.4 255.255.255.0
no sh
int s2/2
ip add 172.16.46.4 255.255.255.0
no sh
int s2/3
ip add 172.16.47.4 255.255.255.0
no sh
router ospf 100
network 172.16.4.0 0.0.0.255 area 0
network 172.16.34.0 0.0.0.255 area 0
network 172.16.45.0 0.0.0.255 area 0
network 172.16.46.0 0.0.0.255 area 0
network 172.16.47.0 0.0.0.255 area 0
end
copy r start
R5
conf t
int e0/0
ip add 172.16.5.254 255.255.255.0
no sh
int s2/0
ip add 172.16.45.5 255.255.255.0
no sh
router ospf 100
network 172.16.5.0 0.0.0.255 area 0
network 172.16.45.0 0.0.0.255 area 0
end
copy r start
R6
conf t
int e0/0
ip add 172.16.6.254 255.255.255.0
no sh
int s2/0
ip add 172.16.46.6 255.255.255.0
no sh
router ospf 100
network 172.16.6.0 0.0.0.255 area 0
network 172.16.46.0 0.0.0.255 area 0
end
copy r start
--------------------------------------------------------
R2
conf t
int e0/0
ip add 172.16.2.254 255.255.255.0
no sh
int s2/0
ip add 172.16.12.2 255.255.255.0
no sh
int s2/1
ip add 172.16.23.2 255.255.255.0
no sh
router ospf 100
network 172.16.2.0 0.0.0.255 area 1
network 172.16.12.0 0.0.0.255 area 1
network 172.16.23.0 0.0.0.255 area 1
end
copy r start
R3
conf t
int e0/0
ip add 172.16.3.254 255.255.255.0
no sh
int s2/0
ip add 172.16.23.3 255.255.255.0
no sh
int s2/1
ip add 172.16.34.3 255.255.255.0
no sh
router ospf 100
network 172.16.3.0 0.0.0.255 area 1
network 172.16.23.0 0.0.0.255 area 1
network 172.16.34.0 0.0.0.255 area 0
end
copy r start
----------------------------------------------------------------
R7
conf t
int e0/0
ip add 172.16.7.254 255.255.255.0
no sh
int s2/0
ip add 172.16.47.7 255.255.255.0
no sh
int s2/1
ip add 172.16.78.7 255.255.255.0
no sh
router ospf 100
network 172.16.7.0 0.0.0.255 area 0
network 172.16.47.0 0.0.0.255 area 0
network 172.16.78.0 0.0.0.255 area 2
end
copy r start
R8
conf t
int e0/0
ip add 172.16.8.254 255.255.255.0
no sh
int s2/0
ip add 172.16.78.8 255.255.255.0
no sh
int s2/1
ip add 172.16.89.8 255.255.255.0
no sh
router ospf 100
network 172.16.8.0 0.0.0.255 area 2
network 172.16.78.0 0.0.0.255 area 2
network 172.16.89.0 0.0.0.255 area 2
end
copy r start
R9
conf t
int e0/0
ip add 172.16.9.254 255.255.255.0
no sh
int s2/0
ip add 172.16.89.9 255.255.255.0
no sh
router ospf 100
network 172.16.9.0 0.0.0.255 area 2
network 172.16.89.0 0.0.0.255 area 2
end
copy r start
--------------------------------------------------------
R10
conf t
int e0/0
ip add 192.168.1.254 255.255.255.0
no sh
int s2/0
ip add 172.16.110.10 255.255.255.0
no sh
router rip
version 2
network 192.168.1.0
network 172.16.110.0
no auto-summary
end
copy r start
----------------------------------------------------------
R1
conf t
int e0/0
ip add 172.16.1.254 255.255.255.0
no sh
int s2/0
ip add 172.16.12.1 255.255.255.0
no sh
int s2/1
ip add 172.16.110.1 255.255.255.0
no sh
router rip
version 2
network 172.16.110.0
no auto-summary
router ospf 100
network 172.16.1.0 0.0.0.255 area 1
network 172.16.12.0 0.0.0.255 area 1
exit
router rip
redistribute ospf 100 metric 1
exit
router ospf 100
redistribute rip subnets
ospf은 기본이 packet이 7갠데, 5개로 보통 정의합니다
1. hello packet ㅎㅇ 님 누구임? 살아있음?
2. DBD Packet 살아있구나, 이거 제 주소에요~
3. LSR packet 자신이 모르는 네트워크가 있으면 상세 주소 주세요 요청 패킷~
4. LSU packet lsr로 주소 받거나, 업데이트 될때 보냄~
5. LSAck Packet 잘 받았어요 고마워요~lsr에 대답해줌, 근데 만약 lsack 신호 안주면 상대방이 무한 lsr 보냄;;
lsack 달라고 ㅋㅋㅋ
ack 긍정응답(잘받았어요 고마워요~)
nackack 부정응답(못받았어요..)-하지만 nack는 상대방한테 안보냄, 왜냐? 나랑 상관없는 패킷은 자체 폐기해버리거든 (굳이 알 필요는 없음)
priority(우선순위)는 DR, BDR 선출할 때 사용
-0~255
-생략시 기본값으로 1 할당
-우선 순위를 0으로 지정하면 DR/BDR 선출에 참가하지않는다
-높은 숫자가 우선순위가 높다
opsf는 area & routing protocol에 따라서 7개의 레벨로 구분한다
sh ip ospf database 명령어로 7개의 레벨 정보 확인 가능
1단계에서는 단일 area만 보여요(r4는 백본이라 0만 보임) r3에서 보면?
Packet type1번 = lsa packet type (나랑 같은 area(Inter Router) 정보들이 보임)
sh ip ospf database router
Packet type 2번 (DR 빨리 볼 수 있는 명령어) DR은 ospf 이중화 있을때 루핑 방지용
sh ip ospf database network
Packet type 3번
sh ip ospf database summary
Packet type 4번(asbr 라우터를 알아줌. 재분배해주는 라우터를 알려줌 = R1, 즉 인터넷 관문으로 나가는 라우터를 보여줌)
sh ip ospf database asbr-summary
Packet type 5번
sh ip ospf database external (요것도 abr) 보여주는거임
DR은 무조건 이중화시 루핑 방지용
DR 선출시 처음엔, Priority로 선출, 없으면 Loopback 넘버로 없으면, 아이피 주소로, 없으면 인터페이스 주소까지 봅니다
1224-01 ospf lab 세팅
Type1 O sh ip ospf database router
Type2 O sh ip ospf database network(DR이 생성)
Type3 O IA sh ip ospf database summary
Type4 O IA sh ip ospf database asbr-summary
Type5 O E2 sh ip ospf database external
Type6 N1 특수용도
Type7 N2 특수용도
R1에서 확인해보기
R2에서 확인해보기
R3에서 확인해보기
R4에서 확인해보기
R5에서 확인해보기
오후 4:20 2024-12-24
1224-01 OSPF config
PC1
ip 172.16.1.1/24 172.16.1.254
PC2
ip 172.16.1.2/24 172.16.1.254
PC3
ip 172.16.2.3/24 172.16.2.254
PC4
ip 172.16.2.4/24 172.16.2.254
PC5
ip 172.16.3.5/24 172.16.3.254
PC6
ip 172.16.3.6/24 172.16.3.254
PC7
ip 172.16.4.7/24 172.16.4.254
PC8
ip 172.16.4.8/24 172.16.4.254
PC9
ip 192.168.5.9 192.168.5.254
PC10
ip 192.168.5.10 192.168.5.254
------------------------------------------------------------------
R1
conf t
int e0/0
ip add 172.16.1.254 255.255.255.0
no sh
int s2/0
ip add 172.16.12.1 255.255.255.0
no sh
router ospf 1
network 172.16.1.0 0.0.0.255 area 1
network 172.16.12.0 0.0.0.255 area 1
end
copy r start
-----------------------------------------------
R2
conf t
int e0/0
ip add 172.16.2.254 255.255.255.0
no sh
int s2/0
ip add 172.16.12.2 255.255.255.0
no sh
int s2/1
ip add 172.16.23.2 255.255.255.0
no sh
router ospf 1
network 172.16.2.0 0.0.0.255 area 0
network 172.16.12.0 0.0.0.255 area 1
network 172.16.23.0 0.0.0.255 area 0
end
copy r start
------------------------------------------------------------
R3
conf t
int e0/0
ip add 172.16.3.254 255.255.255.0
no sh
int s2/0
ip add 172.16.23.3 255.255.255.0
no sh
int s2/1
ip add 172.16.34.3 255.255.255.0
no sh
int s2/2
ip add 192.168.35.1 255.255.255.0
no sh
router ospf 1
network 172.16.3.0 0.0.0.255 area 0
network 172.16.23.0 0.0.0.255 area 0
network 172.16.34.0 0.0.0.255 area 2
router eigrp 1
network 192.168.35.0 0.0.0.255
no auto-summary
exit
router eigrp 1
redistribute ospf 1 metric 1544 2000 255 1 1500
exit
router ospf 1
redistribute eigrp 1 subnets
end
copy r start
-----------------------------------------------------
R4
conf t
int e0/0
ip add 172.16.4.254 255.255.255.0
no sh
int s2/0
ip add 172.16.34.4 255.255.255.0
no sh
router ospf 1
network 172.16.4.0 0.0.0.255 area 2
network 172.16.34.0 0.0.0.255 area 2
end
copy r start
---------------------------------------------------------
R5
conf t
int s2/0
ip add 192.168.35.2 255.255.255.0
no sh
int e0/0
ip add 192.168.5.254 255.255.255.0
no sh
exit
router eigrp 1
network 192.168.5.0 0.0.0.255
network 192.168.35.0 0.0.0.255
no auto-summary
end
copy r start
totally stuby area는 stub area 선언한것만 가능
근데 stub area 선언안해도 NSSA 사용하면 totally stuby area 가능
R3에서 stub 선언 안한 상태에서 totally 선언하면 이렇게 오류가 난다
backbone interface 에서는 stub이 안된다
R3는 ASBR이다 ASBR도 stub 선언도 안된다
stub 선언이 안되는 두가지 경우가 있는데
1. backbone int는 선언이 안됨 (area xx)
2. ASBR이거나
1224-02 OSPF NSSA LAB 세팅
오후 5:43 2024-12-24
1224-02 OSPF NSSA LAB CONFIG
주의
라우팅 프로토콜이 다르면, 네트워크 대역대가 달라야함
- 서브넷이 같다
- RIP, EIGRP 재분배가 필요하다
- AREA는 총 3개
PC1
ip 172.16.1.1/24 172.16.1.254
PC2
ip 172.16.1.2/24 172.16.1.254
PC3
ip 172.16.2.3/24 172.16.2.254
PC4
ip 172.16.2.4/24 172.16.2.254
PC5
ip 172.16.3.5/24 172.16.3.254
PC6
ip 172.16.3.6/24 172.16.3.254
PC7
ip 172.16.4.7/24 172.16.4.254
PC8
ip 172.16.4.8/24 172.16.4.254
PC9
ip 192.168.5.9/24 192.168.5.254
PC10
ip 192.168.5.10/24 192.168.5.254
PC11
ip 192.168.6.11/24 192.168.6.254
PC12
ip 192.168.6.12/24 192.168.6.254
-------------------------------------------
R1
conf t
int e0/0
ip add 172.16.1.254 255.255.255.0
no sh
int s2/0
ip add 172.16.12.1 255.255.255.0
no sh
router ospf 1
network 172.16.1.0 0.0.0.255 area 1
network 172.16.12.0 0.0.0.255 area 1
end
copy r start
--------------------------------------------------------
R2
conf t
int e0/0
ip add 172.16.2.254 255.255.255.0
no sh
int s2/0
ip add 172.16.12.2 255.255.255.0
no sh
int s2/1
ip add 172.16.23.2 255.255.255.0
no sh
int s2/2
ip add 192.168.25.2 255.255.255.0
no sh
router ospf 1
network 172.16.2.0 0.0.0.255 area 0
network 172.16.12.0 0.0.0.255 area 1
network 172.16.23.0 0.0.0.255 area 0
router rip
version 2
network 192.168.25.0
no auto-summary
end
copy r start
conf t
router rip
redistribute ospf metric 1
exit
router ospf 1
redistribute rip subnets metric-type 2
-----------------------------------------------------------
R3
conf t
int e0/0
ip add 172.16.3.254 255.255.255.0
no sh
int s2/0
ip add 172.16.23.3 255.255.255.0
no sh
int s2/1
ip add 172.16.34.3 255.255.255.0
no sh
router ospf 1
network 172.16.3.0 0.0.0.255 area 0
network 172.16.23.0 0.0.0.255 area 0
network 172.16.34.0 0.0.0.255 area 2
end
copy r start
---------------------------------------------------------
R4
conf t
int e0/0
ip add 172.16.4.254 255.255.255.0
no sh
int s2/0
ip add 172.16.34.4 255.255.255.0
no sh
int s2/1
ip add 192.168.46.4 255.255.255.0
no sh
router ospf 1
network 172.16.4.0 0.0.0.255 area 2
network 172.16.34.0 0.0.0.255 area 2
router eigrp 1
network 192.168.46.0 0.0.0.255
no auto-summary
end
copy r start
conf t
router ospf 1
redistribute eigrp 1 subnets metric-type 2
router eigrp 1
redistribute ospf 1 metric 1544 2000 255 1 1500
end
copy r start
----------------------------------------------------
R5
conf t
int s2/0
ip add 192.168.25.5 255.255.255.0
no sh
int e0/0
ip add 192.168.5.254 255.255.255.0
no sh
router rip
version 2
network 192.168.25.0
network 192.168.5.0
no auto-summary
end
copy r start
----------------------------------------------------------
R6
conf t
int s2/0
ip add 192.168.46.6 255.255.255.0
no sh
int e0/0
ip add 192.168.6.254 255.255.255.0
no sh
router eigrp 1
network 192.168.6.0 0.0.0.255
network 192.168.46.0 0.0.0.255
no auto-summary
end
copy r start
'Study > Information Security' 카테고리의 다른 글
저장용 (0) | 2024.12.27 |
---|---|
클라우드 정보 보안 수업 자료 및 정리 [23회차, ospf, nssa, stub, virutal-link, tunneling, acl ] (0) | 2024.12.26 |
클라우드 정보 보안 수업 자료 및 정리 [21회차,RAID, OSPF DR,BDR] (0) | 2024.12.23 |
클라우드 정보 보안 수업 자료 및 정리 [20회차, RAID, OSPF, OSPF redistribute, ASBR, ABR] (1) | 2024.12.20 |
클라우드 정보 보안 수업 자료 및 정리 [19회차,윈도우 부팅 과정, CS, 네트워크,dynamic default route, MariaDB ] (4) | 2024.12.19 |